We are pleased to announce that the incident affecting SalesHood accessibility has been resolved, and all services are now operating as expected. We appreciate your patience and understanding during this time.
Resolved Incident Details:
-
Start Time: Around 4:35 AM PST, Apr 23, 2026
-
Resolution Time: Around 5:15 AM PST, Apr 23, 2026
-
Issue: Accessing the SalesHood app was resulting into a White screen
Verification:
We have conducted thorough testing to ensure that all systems are functioning as expected. Our monitoring systems indicate that the application is now stable, and you should be able to use SalesHood without any further disruptions.
We apologize for any inconvenience this may have caused, and we thank you for your understanding during this time.